S2 - Inability to Reserve Spaces & Room via Mobile App for Android and iOS
Incident Report for SiQ
Postmortem

SiQ Detailed Root Cause Analysis – Severity 2 – March 7, 2023

Reservations on SpaceIQ Mobile Application

Description:

On Friday, March 3, 2023, at approximately 5:30am MST, customer support began to receive reports of issues on the SpaceIQ mobile application, on both Android and iOS and the inability to reserve a desk.

 

Type of Event:

Service Disruption

 

Services\Modules Impacted:

Mobile Application

 

Timeline:

On Friday, March 3, 2023, at approximately 5:30am MST, customer support began to receive reports on the inability to reserve a desk via SpaceIQ mobile application. The initial ticket was escalated to a Severity 2 incident on Monday, March 6th at 10:13am MST and posted to our status page alerting customers. Internal teams acknowledge the issue and being an investigation at 10:16am. 2:11pm MST, our internal teams have identified the issue and begin to implement a fix. The fix included a full build of the code changes to our mobile application. Internal teams submitted the updates to the app stores for Android and iOS. On Tuesday, March 7th, 7:38pm MST internal teams were notified by the app stores that updates were published. Internal teams verified the fix was successful at 8:16pm. Customers were alerted at 10:28pm via status page and support tickets that the issue has been resolved.  

 

Total Duration of Event:

4 days, 14 hours, 46mins

 

Root Cause Analysis:

We found the root cause to be from a tool that is used to push mobile changes quickly/efficiently, had failed. This resulted to a full build which caused a delayed fix on the mobile application.

Preventative Action:

Internal teams are investigating the tool used to push changes to the mobile application. In the meantime, all mobile fixes and new releases will be planned accordingly, as a full build will be necessary until the tool is fixed.

Posted Mar 10, 2023 - 20:46 UTC

Resolved
Our engineering team has verified that the fixes for the SpaceIQ mobile application have been approved for both Android & iOS. The verified changes have been updated successfully. When making reservations on your mobile device, please ensure that you are using version 1.0.42. If you have additional questions, please reach out to our support team at support-siq@eptura.com. There will be a detailed RCA posted within the next 10 business days. We appreciate your patience through this Service Disruption.
Posted Mar 08, 2023 - 05:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 07, 2023 - 23:22 UTC
Update
We continue to wait on the fix to be approved through the App Stores. We appreciate your patience and will continue to provide updates throughout the day.
Posted Mar 07, 2023 - 18:37 UTC
Update
The wait for the submitted fixes to the App Store continue, and the current workaround to use the Webb Application to reserve Spaces or Rooms remain the same. We appreciate your patience. Our next update will be 11:23am MST.
Posted Mar 07, 2023 - 14:23 UTC
Update
Our engineering team has submitted the needed fixes to the App Store for both Android & iOS and are awaiting approval. This can take up to 24hrs. However, we will continue to provide active updates.
Posted Mar 07, 2023 - 06:20 UTC
Update
We are continuing to work on a fix for this issue. Our next update will be 9:54pm MST.
Posted Mar 07, 2023 - 00:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 06, 2023 - 21:11 UTC
Investigating
We are currently investigating the issue on the "Inability to Reserve Spaces & Room via Mobile Application for Android and iOS". We are asking if you access to SpaceIQ via Web Application, please reserve your Space or Room here. We will have another update at 2:13pm MST.
Posted Mar 06, 2023 - 17:13 UTC
This incident affected: Apps (Mobile App).