Intermittent Performance or Access Issues
Incident Report for SiQ
Postmortem

SpaceIQ Detailed Root Cause Analysis – (February 2, 2023)

S2 – Inability to Access SpaceIQ Application (Intermittently)

Description:

On February 2, 2022, at approximately 12:56pm MST, customer support received an initial report on the inability to access the SpaceIQ platform, intermittently.

 

Type of Event:

Service Disruption

 

Services\Modules Impacted:

SpaceIQ Platform

 

Remediation:

A release that was deployed caused this issue and new a new process was put in place to deploy server changes after business hours or when our customers will be less impacted.

 

Timeline:

At approximately 12:56pm MST Internal teams and customers have reported the intermittent issue on the inability to access the SpaceIQ software. Internal teams acknowledge the issue and begin investigation around 1:19pm MST. After an investigation and information gathering to reproduce customers experiences. The initial ticket was escalated to an S2 incident at 4:26pm MST and posted to our status page alerting customers. Internal teams found that the cause was from a deploy that started 9:00am and finished around 9:30am MST. After the deploy, we found some internal processes restarted which caused the intermittent behavior. Our internal teams began to revert the deploy to resolve the issue and revisit internal processes till 10:00pm MST. Monitoring continued till the morning of February 3, 2023, and the status page was marked as resolved at 11:49am.

Posted Feb 16, 2023 - 21:03 UTC

Resolved
Our teams have quickly identified the issue and implemented a fix. This incident has now been resolved.
Posted May 10, 2022 - 18:05 UTC
Investigating
Currently our internal teams are investigating this issue.
Posted May 10, 2022 - 17:14 UTC
This incident affected: System Status.