Desk Booking
Incident Report for SiQ
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 19:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2022 - 17:11 UTC
Identified
We are currently experiencing an issue with completing room bookings. Our technical teams are currently working hard to resolve this matter as a matter of urgency.

In the mean time, this behavior should be avoidable by clearing your browser cache or opening SiQ in a browser incognito window.

We apologize for the inconvenience that this may cause and a further update to this issue will be posted here next either when we resolve this behavior or by 2:30 PM EDT, whichever is sooner.
Posted Apr 11, 2022 - 17:11 UTC
This incident affected: Desk Reservation Module.