S1 - Intermittent Performance and Site access intermittent
Incident Report for SiQ
Postmortem

SiQ Preliminary Event Analysis – Severity 1 – September 29, 2022

Description:

On September 2, 2022, at approximately 9:57am MDT, following a product release, customers began to report errors navigating the SiQ platform. “Network Request Failed”

 

Type of Event:

Outage

 

Services\Modules Impacted:

SiQ Production

 

Remediation:

Production firewall did not allow new information required for loading the web app. Internal teams engaged to allow new information to load.

 

Timeline:

Thursday, September 29, 2022

9:57am MDT: First Customer reported errors navigating this SiQ platform.

11:45am MDT: After multiple customers reported the similar issues, support pulled the Fire Alarm and internal teams were notified.

11:47am MDT: Engineering acknowledged the issue and began investigating.

11:50am MDT: The SiQ status page was posted as investing for clients.

11:54am MDT: The new release was reverted, and engineering teams started to implement fix.

11:57am MDT: The SiQ status page was posted as the issue had been identified

12:13pm MDT: Support verifies with customers and confirms this is still and issue.

1:04pm MDT: SiQ status page updated as team has identified the issue.

1:09pm MDT: Engineering confirms a fix has been implemented and support confirms with customers.

1:13pm MDT: SiQ status page marked as Resolved.  

 

Total Duration of Event:

3hrs 15mins

Posted Oct 21, 2022 - 19:03 UTC

Resolved
The fix has been deployed and this issue has been resolved.
Posted Sep 29, 2022 - 19:13 UTC
Update
Our engineering teams continue to implement the fix for the identified issue. We will have another update within the next hour.
Posted Sep 29, 2022 - 19:04 UTC
Identified
The issue has been identified by our engineering team and a fix is being implemented.
Posted Sep 29, 2022 - 17:57 UTC
Investigating
We are currently investigating this issue.
Posted Sep 29, 2022 - 17:50 UTC
This incident affected: System Status, Desk Reservation Module, Employee Import Module, Insights Module, Move Module, Room Calendar Module, Slack app and Apps (Web App, Mobile App, Kiosk App).